"Book" and "Book and Pay" buttons can become non responsive on appointment booking from studio dashboard

Incident Report for Momence

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 19:42 UTC

Identified

Engineering has identified the issue and a fix is being prepared.

Customers can still book from the customer facing schedule.
Posted Jul 23, 2026 - 18:03 UTC
This incident affected: Dashboard.